Cocoonアップデートすると「Fatal error: Can’t use function return value in write context in〜」というエラー

技術的なこと
スポンサーリンク

4月からWordPressのテーマをCocoonにしております。

先日までVer0.5.1.1を利用していたのですが、

Ver0.7にバージョンアップしたところ以下のエラー。

「Fatal error: Can’t use function return value in write context in <WordPressインストール先>/wp-content/themes/cocoon-master/lib/html-forms.php on line 976」

他のページに遷移することすらできず、

どうにもなりません。困り果てました。

スポンサーリンク

やったこと

 

①FTPでログインしてテーマフォルダを削除

→WordPress管理画面が表示されるようになる。

再度0.5.1.1をインストールすると正常に表示される。

②PHPを5.3から7へバージョンアップ

→0.7にバージョンアップしたところ、正常に使えるようになりました。めでたしめでたし。

PHPは7にしておきましょう。

 

Cocoon公式ページにもある通り、

PHPはバージョンアップしておきましょうということですね。

身にしみました。

コメント